IS-IS EcoRouter Documentation / Routing / IS-IS
- Configuration example
- Redistribution, filtering and route summarizing
- Default routes and mesh-groups
- Additional configuration commands
- Viewing commands
IS-IS (Intermediate System to Intermediate System) — the dynamic routing internal protocol.
The configuring process of IS-IS protocol consists of several steps. After IS-IS network design is selected the basic configuring is to enable IS-IS protocol on a routers, configuring a unique NET-address and enabling a protocol on interfaces.
Configuration steps:
Step 1.
Enter the protocol configuration mode using the router isis <process name> command, where process name can be set of letters and numbers or be omitted.
Step 2.
Configure router's NET-address using the net <address> command, where address length should be from 8 to 20 byte. The last byte is a n-selector (SEL) and must be set to 0. The 6th byte before the n-selector is a system identifyer (System-ID), the bytes 1th-13th are area idenrifyer (area ID). By default a router can have 3 NET-addresses in a different areas, but system identifyer must be the same. Use the max-area-address <value> command to increase a number of NET-addresses.
Step 3.
To specify the level which the router would work on in the IS-IS protocol configuration mode use the is-type <level-1/level-1-2/level-2-only> command, by default it's L1/L2. One can specify connection type on interface using the isis circuit-type <level-1/level-1-2/level-2-only> command, by default it's L1/L2.
Step 4.
To specify the network type in the interface configuration mode use the isis network command. The possible network type is broadcast or point-to-point.
Step 5.
To specify timers' values in the interface configuration mode use the isis hello-interval command or change the multiplier hold-timer by using the isis hello-multiplier <value> command.
Step 6.
Configure manually interfaces' costs for best route choice affecting. To do this in interface configuration mode use the isis metric <value> command.
Step 7.
IS-IS protocol authentification. The EcoRouterOS supports clear-text and md5 authentification via key chains.
Configure an authentification on each one interface separately. For clear-text authentification configuringe in the configuration interface mode use the isis password <string> [level-1/level-2] command, where string's maximum length is 254 symbols. To configure md5 authentificzation use the isis authentication mode md5 and the isis authentication key-chain <key chain's name> [level-1/level-2] commands. To specify the key chain's name in the key chain configuration mode use the key chain <key chain's name> command, one can specify several passwords and key chain names.
Configuration example
Step 1. Specifying device name.
ecorouter(config)#hostname ECO-1
Step 2. Ports, interfaces and service instanse configuring.
ecorouter(config)#interface e2
ecorouter(config-if)#ip address 10.12.0.1/16
ecorouter(config)#interface e3
ecorouter(config-if)#ip address 10.13.0.1/16
ecorouter(config)#port ge2
ecorouter(config-port)#service-instance ge2/e2
ecorouter(config-service-instance)#encapsulation untagged
ecorouter(config-service-instance)#connect ip interface e2
ecorouter(config)#port ge2
ecorouter(config-port)#service-instance ge2/e2
ecorouter(config-service-instance)#encapsulation untagged
ecorouter(config-service-instance)#connect ip interface e2
Step 3. Routing enabling.
ecorouter(config)#router isis
ecorouter(config-router)#net 49.0001.0000.0000.0001.00
ecorouter(config-router)#exit
ecorouter(config)#interface e2
ecorouter(config-int)#ip router isis
ecorouter(config-int)#interface e3
ecorouter(config-int)#ip router isis
ecorouter(config-int)#exit
Step 4. Authentification between neighbors enabling.
ecorouter(config)#key chain test
ecorouter(config-keychain)#key 1
ecorouter(config-keychain-key)#key-string ecorouter
ecorouter(config-keychain-key)#exit ecorouter(config-keychain)#exit ecorouter(config)#interface e2 ecorouter(config-if)#isis authentication mode md5 ecorouter(config-if)#isis authentication key-chain test ecorouter(config)#interface e3 ecorouter(config-if)#isis authentication mode md5 ecorouter(config-if)#isis authentication key-chain test
The other routers should be configured in the same way.
hostname ECO-2
key chain test2
key 2
key-string 0x8de456332b943f870ef377482f699e4c
interface e1
ip address 10.12.0.2/16
ip router isis
interface e3
ip address 10.23.0.2/16
ip router isis
port ge1
service-instance ge1/e1
encapsulation untagged
connect ip interface e1
port ge2
service-instance ge2/e2
encapsulation untagged
connect ip interface e2
router isis
net 49.0001.0000.0000.0002.00
hostname ECO-3
key chain test3
key 3
key-string 0x8de456332b943f870ef377482f699e4c
interface e1
ip address 10.13.0.3/16
ip router isis
interface e2
ip address 10.23.0.3/16
ip router isis
port ge1
service-instance ge1/e1
encapsulation untagged
connect ip interface e1
port ge2
service-instance ge2/e2
encapsulation untagged
connect ip interface e2
router isis
net 49.0001.0000.0000.0003.00
Redistribution, filtering and route summarizing
One can permit or deny subnet routing information transmition when redistributing routes are from different IS-IS levels. One can configure policy-filter-list, route-map with the permit или deny rules and apply them to the distribute-list (to read more about lists and route maps see the relevant sections). The configuration command is redistribute isis <level-1/level-2 > into <level-2/level-1> distribute-list <name>.
Only route-maps to manage route information transfer from another routing protocol can be used. The configuration command is redistribute <connected/static/rip/ospf/bgp> [metric <0-63>] [metric- type <internal/external>] [level-1/level-2/level-1-2] [route-map <name>].
Use the summary-address <address/mask> [level-1/level-2/level-1-2] [metric <0-63>] command for routes summarising.
Use the metric <значение > [ systemID <policy-filter-list ID>] command to specify the administrative distance value for IS-IS routes, where systemID is system neighbor identifyer (this neighbor advertises subnets).
Default routes and mesh-groups
To reduce IS-IS routing table size EcoRouterOS allows to configure advertising default routes to the neighbors. When connecting L1/L2 router to different areas in route advertising the default route will be sent to L1-neighbor. The L1/L2 router's address will be sent as a next-hop address. To send the default route to neighbor use the default-information originate [always] [route-map] command, where the always parameter doesn't take into account if the default route is in its own routing table, the route-map parameter allows to select a particular subnet.
To control LSP flooding in NBMA links EcoRouterOS allows to add interfaces into different mesh-groups which sets some specific rules on subnet information packets handling.
In the interface configuration mode the command is isis mesh-group <value/blocked>. If LSP is recieved onto interface which is not in the mesh-group, the LSP transmits further usually. If LSP is recieved onto interface which is in the mesh-group, the LSP transmits further to all interfaces excluding which are in the same group or marked as blocked.
Additional configuration commands
See additional IS-IS protocol configuration commands in the table below.
Command | Mode | Description |
---|---|---|
ignore-lsp-errors | (config-router)# | Ignoring LSP with check-sum errors |
ispf | (config-router)# | Enabling an incremental SPF |
lsp-gen-interval | (config-router)# | Setting LSP regeneration period |
lsp-mtu | (config-router)# | MTU size for LSP |
lsp-refresh-interval | (config-router)# | LSP refresh peiod |
max-lsp-lifetime | (config-router)# | LSP lifetime |
passive-interface | (config-router)# | Specifying passive interface |
prc-interval-exp | (config-router)# | PRC intervals setting |
restart-timer | (config-router)# | IS-IS timer restart setting |
set-overload-bit | (config-router)# | Overload bit setting |
spf-interval-exp | (config-router)# | SPF interval setting |
isis csnp-interval | (config-int)# | CSNP interval setting |
isis hello padding | (config-int)# | Decreasing Hello message size |
isis lsp-interval | (config-int)# | LSP interval setting |
isis priority | (config-int)# | Priority setting |
isis retransmit-interval | (config-int)# | LSP retransmit period setting |
clear isis process | # | Routing process discarding |
Viewing commands
See protocol infromation related commands in the table below. Just like the other show commands they support modificators using.
Command | Description |
---|---|
show isis counter | Shows quantitative information about IS-IS messages |
show isis database | Shows summary information about database content |
show isis database detail | Shows total information about database content |
show isis interface | Shows interfaces parameters included into routing process |
show isis topology | Shows content information from database topology |
show clns neighbors | Shows information about neighbors |
show clns protocol | Shows general protocol information |